-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Apps
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans (48) . 

Impulse - PulseAudio visualizer

   0.5.5  

Screenlet

Score 81%
Impulse - PulseAudio visualizer
zoom


Impulse - PulseAudio visualizer
zoom


Impulse - PulseAudio visualizer
zoom


Homepage:  Link
Downloads:  58071
Submitted:  Feb 14 2009
Updated:  Dec 12 2010

Description:

Impulse is a bit of eye-candy for your desktop. It is a widget that displays a graphical spectrum analyzer on your gnome desktop. It is written in c and python and uses GTK and cairo graphics to generate the animation. the impulse library creates a pulse audio connection context that reads the output stream from pulseaudio in a thread natively which can then be read from python. You can specify impulse to either output the raw stream or output the fft of the raw stream.


Requires:
screenlets 1.2
libfftw3-3
libpulse0


Install:
1) Download and extract Impulse.tar.bz2
2) mv Impulse ~/.screenlets/
then open up the screenlets manager and start Impulse or open screenlets manager and click Install, navigate to the Impulse.tar.bz2 archive and click ok.




Changelog:

Impulse 0.5.5
Fixed issue cause by latest Ubuntu update and added ability to change the audio source. Also updated the default theme.

Impulse 0.5.0
New structure. Themes now editable.

Impulse 0.2.4
Fixed screenlet menu bug and use a smarter way to identifying the pa monitor source.

Impulse 0.2.2
Added new screenlet themes

Impulse 0.2.0
Project is under a new name, Impulse. Now natively captures PulseAudio output source

Spectrolet 0.1.4:
Switched from ESOUND to Pulseaudio

Spectrolet 0.1.2:
Now preforms an fft on the audio stream

Spectrolet 0.1.0:
Now uses gtk.main correctly










LicenseGPL
(Impulse screenlet x86)
(Impulse screenlet x86_64)
(Impulse All)
Send to a friend
Subscribe
Other  Apps  from ianimal
Report inappropriate content



goto page: prev   1  2  3  4  5  6  7  8  9  10  11  12  13 ...

-

 wont launch

 
 by chaoticseraph on: Jun 19 2009
 
Score 50%

I installed it correctly, when I click add/launch on the screenlets manager, nothing happens at all. I'm new to ubuntu, and I'm not sure how to fix this by myself. Any help?


Reply to this

-

 Re: wont launch

 
 by ianimal on: Jun 20 2009
 
Score 50%

Click on Impulse in the screenlets manager and click "Close All" on the left side bar. Hit "Alt+F2" and type in "gnome-terminal", then click run. When the terminal pops up type in this command:

.screenlets/Impulse/ImpulseScreenlet.py

If the output is long just P.M. it to me otherwise just reply to this comment with the output.


Reply to this

-

 Re: Re: wont launch

 
 by chaoticseraph on: Jun 21 2009
 
Score 50%

I did what you said, and this is what it gave me in the terminal.

laura@Anemane:~$ .screenlets/Impulse/ImpulseScreenlet.py
CachingBackend: Loading instances from cache
No global tempdir found, creating new one.
Temp directory /tmp/screenlets created.
Creating new entry for ImpulseScreenlet in /tmp/screenlets/screenlets.laura.running
Loading instances in: /home/laura/.config/Screenlets/Impulse/default/
No instance(s) found in session-path, creating new one.
/home/laura/.config/Screenlets/Impulse/default/Impulse1
Traceback (most recent call last):
File ".screenlets/Impulse/ImpulseScreenlet.py", line 119, in <module>
screenlets.session.create_session( ImpulseScreenlet )
File "/usr/lib/python2.6/dist-packages/screenlets/session.py", line 472, in create_session
session.start()
File "/usr/lib/python2.6/dist-packages/screenlets/session.py", line 246, in start
sl = self.screenlet(session=self, id=self.__get_next_id())
File ".screenlets/Impulse/ImpulseScreenlet.py", line 47, in __init__
import impulse
ImportError: /home/laura/.screenlets/Impulse/impulse.so: wrong ELF class: ELFCLASS64


Reply to this

-

 Re: Re: Re: wont launch

 
 by ianimal on: Jun 21 2009
 
Score 50%

Ah, ok. So go into the Screenlets manager, click on Impulse and click uninstall. Then click the 1st download link on this site, it is labled "Impulse screenlet x86", download it, and install that one. You must have just downloaded the 64 bit version whereas your cpu is 32 bit.


Reply to this

-
.

 Re: Re: Re: Re: wont launch

 
 by chaoticseraph on: Jun 22 2009
 
Score 50%

That worked. Thank you. Sorry for the hassle.


Reply to this

-

 two sound cards

 
 by bulis88 on: Jun 27 2009
 
Score 50%

thanx for this great screenlet. It's the best screenlet ever.
I'm using Jaunty and have two sound cards... one intergrated HDA Intel and the other one is SB Live PCI. When I listen music over HDA Intel there are no visualisations in this screenlet. I have to move the stream to the other soundcard to be able to see the visualisations. Is there any way to fix this issue?thx


Reply to this

-
.

 working on gentoo

 
 by pinklerose on: Jun 28 2009
 
Score 50%
pinklerosepinklerose
pinklerose.p l
Home

Maybe someone run this screenlet on gentoo with success?


http://pinklerose.pl
Reply to this

-
.

 No pulseaudio

 
 by protic on: Jul 3 2009
 
Score 50%

Hi,
if u guys don't know we need to remove pulseaudio completely to run skype successfully, however the screenlet seems amazing can u guys please tell me how to get it to work with alsa sound system?


Reply to this

-
.

 Looks wonderful

 
 by colordrops on: Jul 7 2009
 
Score 50%

but it seems to only sample the music every 5 seconds or so, so it gets stuck in the same shape until the next update, not moving at all. What's going on?


Reply to this

-

 Wonderful, but not working!

 
 by Dalle1985 on: Jul 18 2009
 
Score 50%

Okay, so this is really bugging me: I installed the screenlet without a problem, but when i try to launch it, nothing happens... So I tried some different things, but nothing worked.
I launched it in a terminal just to see what was happening, but no errors occured, it just said that it was overiding options because it found a theme.

I've also tried uninstalling it and reinstalling it (several times), but to no avail.

By accident however (compiz crashed) I found out that as soon as compiz isn't running, "Impulse" works fine. By typing "emerald --replace" which makes all my window decorations look really bad, Impulse starts, so it seems to be some sort of conflict with compiz.

I'm running Ubuntu Jaunty BTW.


Reply to this

goto page: prev   1  2  3  4  5  6  7  8  9  10  11  12  13 ...

Add commentBack






-
 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Apps
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
Events RSS   

Participate
Groups
Forum
Add App
Public API
About GTK-Apps.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2007-2014 GTK-Apps.org Team  
All rights reserved. GTK-Apps.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.