-
 KDE-Apps.org Applications for the KDE-Desktop 
 GTK-Apps.org Applications using the GTK Toolkit 
 GnomeFiles.org Applications for GNOME 
 MeeGo-Central.org Applications for MeeGo 
 CLI-Apps.org Command Line Applications 
 Qt-Apps.org Free Qt Applications 
 Qt-Prop.org Proprietary Qt Applications 
 Maemo-Apps.org Applications for the Maemo Plattform 
 Java-Apps.org Free Java Applications 
 eyeOS-Apps.org Free eyeOS Applications 
 Wine-Apps.org Wine Applications 
 Server-Apps.org Server Applications 
 apps.ownCloud.com ownCloud Applications 
--
-
 KDE-Look.org Artwork for the KDE-Desktop 
 GNOME-Look.org Artwork for the GNOME-Desktop 
 Xfce-Look.org Artwork for the Xfce-Desktop 
 Box-Look.org Artwork for your Windowmanager 
 E17-Stuff.org Artwork for Enlightenment 
 Beryl-Themes.org Artwork for the Beryl Windowmanager 
 Compiz-Themes.org Artwork for the Compiz Windowmanager 
 EDE-Look.org Themes for your EDE Desktop 
--
-
 Debian-Art.org Stuff for Debian 
 Gentoo-Art.org Artwork for Gentoo Linux 
 SUSE-Art.org Artwork for openSUSE 
 Ubuntu-Art.org Artwork for Ubuntu 
 Kubuntu-Art.org Artwork for Kubuntu 
 LinuxMint-Art.org Artwork for Linux Mint 
 Arch-Stuff.org Art And Stuff for Arch Linux 
 Frugalware-Art.org Themes for Frugalware 
 Fedora-Art.org Artwork for Fedora Linux 
 Mandriva-Art.org Artwork for Mandriva Linux 
--
-
 KDE-Files.org Files for KDE Applications 
 OpenTemplate.org Documents for OpenOffice.org
 GIMPStuff.org Files for GIMP
 InkscapeStuff.org Files for Inkscape
 ScribusStuff.org Files for Scribus
 BlenderStuff.org Textures and Objects for Blender
 VLC-Addons.org Themes and Extensions for VLC
--
-
 KDE-Help.org Support for your KDE Desktop 
 GNOME-Help.org Support for your GNOME Desktop 
 Xfce-Help.org Support for your Xfce Desktop 
--
openDesktop.orgopenDesktop.org:   Applications   Artwork   Linux Distributions   Documents    LinuxDaily.com    Linux42.org    OpenSkillz.com   
 
Apps
News
Groups
Knowledge
Events
Forum
People
Jobs
Register
Login


Sponsoring


-
- Content .- Fans (48) . 

Impulse - PulseAudio visualizer

   0.5.5  

Screenlet

Score 81%
Impulse - PulseAudio visualizer
zoom


Impulse - PulseAudio visualizer
zoom


Impulse - PulseAudio visualizer
zoom


Homepage:  Link
Downloads:  58729
Submitted:  Feb 14 2009
Updated:  Dec 12 2010

Description:

Impulse is a bit of eye-candy for your desktop. It is a widget that displays a graphical spectrum analyzer on your gnome desktop. It is written in c and python and uses GTK and cairo graphics to generate the animation. the impulse library creates a pulse audio connection context that reads the output stream from pulseaudio in a thread natively which can then be read from python. You can specify impulse to either output the raw stream or output the fft of the raw stream.


Requires:
screenlets 1.2
libfftw3-3
libpulse0


Install:
1) Download and extract Impulse.tar.bz2
2) mv Impulse ~/.screenlets/
then open up the screenlets manager and start Impulse or open screenlets manager and click Install, navigate to the Impulse.tar.bz2 archive and click ok.




Changelog:

Impulse 0.5.5
Fixed issue cause by latest Ubuntu update and added ability to change the audio source. Also updated the default theme.

Impulse 0.5.0
New structure. Themes now editable.

Impulse 0.2.4
Fixed screenlet menu bug and use a smarter way to identifying the pa monitor source.

Impulse 0.2.2
Added new screenlet themes

Impulse 0.2.0
Project is under a new name, Impulse. Now natively captures PulseAudio output source

Spectrolet 0.1.4:
Switched from ESOUND to Pulseaudio

Spectrolet 0.1.2:
Now preforms an fft on the audio stream

Spectrolet 0.1.0:
Now uses gtk.main correctly










LicenseGPL
(Impulse screenlet x86)
(Impulse screenlet x86_64)
(Impulse All)
Send to a friend
Subscribe
Other  Apps  from ianimal
Report inappropriate content



goto page: prev  ... 5  6  7  8  9  10  11  12  13  14  15  16 

-

 Don't work on Lucid

 
 by ubuntico on: Jun 5 2010
 
Score 50%

This screenlet seems don't work on Ubuntu Lucid, any suggestions?


Reply to this

-

 Re: Don't work on Lucid

 
 by ianimal on: Jun 5 2010
 
Score 50%

Yes, make sure you have all requirements installed in synaptic. Mainly libfftw3-3.


Reply to this

-

 Re: Re: Don't work on Lucid

 
 by versa on: Oct 11 2010
 
Score 50%

i cant get it to work on lucid, i believe i have all of the necisarry librarys installed. is there anything special you need to do for 10.04?


Reply to this

-

 Re: Re: Re: Don't work on Lucid

 
 by ianimal on: Oct 13 2010
 
Score 50%

It works fine on my 10.04 and 10.10. Please just double check for me that libfftw3-3 is installed in the Synaptic Package Manager and that you are downloading the correct architecture for your comp.


Reply to this

-

 Re: Re: Re: Re: Don't work on Lucid

 
 by versa on: Oct 13 2010
 
Score 50%

I have libfftw3-3 installed, and the x86 version installed, i have the bar, it just isnt doing anything... :(
if there is anymore information you need, just let me know (you may need to tell me how to get it, im new to linux)
thank you for your help!


Reply to this

-

 Re: Re: Re: Re: Re: Don't work on Lucid

 
 by din on: Nov 5 2010
 
Score 50%

I had trouble with this the screenlet not doing anything as well until I installed the pulseaudio mixer. This lets you choose which output to use with the screenlet. It's a panel applet so you have to add it first.


Reply to this

-

 wonderful

 
 by nanderz on: Jun 9 2010
 
Score 50%

I love it, thank you.

Had to follow some 'instructions' to get working on Ubuntu 10.04 (64) ;)

Also had to use wget to DL as I saw code when clicking the link


Reply to this

-

 Re: wonderful

 
 by versa on: Oct 11 2010
 
Score 50%

what instructions did you have to follow? ive tried everything and cant figure it out :/ but im also new to linux and might just be overlooking something. any help would be appriciated!
(10.04)


Reply to this

-
.

 problem

 
 by r0ckstarferlife on: Jun 25 2010
 
Score 50%

could you please add an option to choose what audio output it should use because i love this widget but i am using a different output then the default and i am having trouble getting it to work with my "Analog Surround 7.1 + Analog Stereo input"


Thanks, R0ckstar
Reply to this

-

 alsa driver not pulseaudio

 
 by coz on: Jul 3 2010
 
Score 50%
cozcoz
-
coz DS 3

United States of America, Pittsburgh
Last visit Apr 21 2013
0 Friends
0 Groups

More info
Send a message
Add as friend
Other contents
--

Hey guy,,
Very very nice indeed... love it however
Things work if I use pusleaudio but I dont :)
I have a pro sound card that i have to compile my own alsa driver for... the impulse screenlet seems to ONLY work with pulseaudio... is there any way to get this to work with my alsa driver??
At this point if I listen to music and use Impulse...things work well but if I go to youtube or watch a movie etc etc.. I have no sound because the screenlet is calling on pulseaudio and not my alsadriver.
Any help would be greatly appreciated...by the way ..any of us who are using a pro sound card we wouldnt be using pulseaudio by the way! :)*

coz


Reply to this

-

 Works great in 10.04

 
 by 8jwong14 on: Jul 27 2010
 
Score 50%

Thanks for this. It works fantastic in Ubuntu 10.04.


Reply to this

-
.

 It works

 
 by P4NCH1 on: Sep 29 2010
 
Score 50%

Works very fine in Linux Mint 9 (Gnome).
It would be cool if can change colors!

PD: Sorry about my english :S


Programador: mamífero nocturno de ojos rojos capaz de conversar con objetos inanimados.
Reply to this

goto page: prev  ... 5  6  7  8  9  10  11  12  13  14  15  16 

Add commentBack






-
 
 
 Who we are
Contact
More about us
Frequently Asked Questions
Register
Twitter
Blog
Explore
Apps
Jobs
Knowledge
Events
People
Updates on identi.ca
Updates on Twitter
Facebook App
Content RSS   
Events RSS   

Participate
Groups
Forum
Add App
Public API
About GTK-Apps.org
Legal Notice
Spreadshirt Shop
CafePress Shop
Advertising
Sponsor us
Report Abuse
 

Copyright 2007-2014 GTK-Apps.org Team  
All rights reserved. GTK-Apps.org is not liable for any content or goods on this site.
All contributors are responsible for the lawfulness of their uploads.